Navigation Content

Embedded Solutions for Ricoh Devices

 

The devices listed below are supported with a native Equitrac-embedded application. For other devices not listed, Equitrac can still be used for tracking and secure document release via our range of external and web-based solutions. For more information about Equitrac Office and Express, please click here. For Equitrac Professional, please click here for further information. 

  
Ricoh PCC 5 (Print & Copy Control) for Equitrac Office/Express
 
Ricoh Model SOP Version
MP 305 2.1 or higher
MP 501, 601 2.1 or higher
MP 6503, 7503, 9003 2.1 or higher
MP C2004, C2504 2.1 or higher
MP C3004, C3504, C4504, C5504, C6004 2.1 or higher
MP C306Z, 406Z 2.1 or higher

The models listed above are supported with the latest build of PCC 5 and require Equitrac Office/Express 5.6 or higher. Devices with Fiery Controllers are not supported.

 

Ricoh PCC 4 (Print & Copy Control) for Equitrac Office/Express
 
Aficio Model Java Version
MP 2553, 3053, 3353 (***) 11.x is pre-installed
MP 2554, 3054, 3554 12.x is pre-installed
MP 305 (**) 12.34.01 or higher
MP 401SPF (***) 11.x is pre-installed
MP 4054, 5054, 6054 12.x is pre-installed
MP 501, 601 (**) 12.38.04 or higher
MP 6503, 7503, 9003 (**) 12.31.03 or higher
SP 4510SF (***) 11.x is pre-installed
MP C2003SP, C2503SP 11.x is pre-installed
MP C2004, C2504 (**) 12.35.01 or higher
MP C3003, C3503 11.x is pre-installed
MP C3004, C3504, C4504, C5504, C6004 (**) 12.35.01 or higher
MP C306Z, C406Z 12.x is pre-installed
MP C401 12.x is pre-installed
MP C4503, C5503, C6003 11.x is pre-installed
MP C6502, C8002 11.x is pre-installed
Aficio MP 2001SP, 2501SP (***) (*) 10.09 is pre-installed
Aficio MP 2352 7.15.04 or higher
Aficio MP 2550, 3350 4.16 or higher
Aficio MP 2851, 3351 4.18 or higher
Aficio MP 2852, 3352 7.15.04 or higher
Aficio MP 301 (***) 10.09 or higher
Aficio MP 4000, 5000 4.16 or higher
Aficio MP 4001, 5001 4.16 or higher
Aficio MP 4002, MP 5002 10.09 is pre-installed
Aficio MP 6001, 7001, 8001, 9001 5.05 or higher
Aficio MP 6002, 7502, 9002 10.09 is pre-installed
Aficio SP 4520DN (***) 11.x or higher
Aficio SP 5200S, 5210SR/SF 7.13.03 or higher
Aficio SP 8300DN (***) 10.07 or higer
Aficio MP C2050(*), C2550(*) 4.16 or higher
Aficio MP C2051, C2551 7.x is pre-installed
Aficio MP C2800, C3300 4.16 or higher
Aficio MP C3001, C3501 7.x is pre-installed
Aficio MP C3002, C3502 10.09 is pre-installed
Aficio MP C305 (***) 10.09 or higher
Aficio MP C4501, C5501 7.x is pre-installed
Aficio MP C4502, C5502 10.09 is pre-installed
Aficio MP C4000, C5000 4.16 or higher
Aficio MP C6000, C7500 4.16 or higher
Aficio MP C300, C400 7.09 or higher
Aficio MP C6501, C7501 7.x is pre-installed
Aficio SP C830DN (***) 10.07 or higher
AAficio SP C831DN 10.07 or higher
Pro 8100S, 8110S, 8120S
11.x is pre-installed
Pro 907EX, 1107EX, 1357EX 5.05 or higher
Pro C5100S, C5110S (Ricoh Controller Only) 11.x is pre-installed
   

The models listed above are supported with the latest builds PCC 4.2.1 and PCC 4.2.3 unless otherwise noted.

Devices with Fiery Controllers are not supported.

 

(*) Requires 512MB upgrade to run Java solutions.
  

(**) These devices are currently only supported in standard mode with the PCC Java component, needs latest device firmware.  

(***) The Hard Disk Drive option is required to run PCC.

 

 

Ricoh PCC 3 (Print & Copy Control) for Equitrac Office/Express  

 

Aficio Model Java Version

Aficio MP 2510, 3010

N/A

Aficio MP 2550, 3350

N/A

Aficio MP 3500, 4500

N/A

Aficio MP 4000, 5000

N/A

Aficio MP 5500, 6500, 7500

N/A

Aficio MP 6000, 7000, 8000

N/A

Aficio MP 6001, 7001, 8001, 9001

N/A

Aficio MP 9000, 1100, 1350

N/A

Aficio MP C2000, C2500, C3000

N/A

Aficio MP C2050, C2250

N/A

Aficio MP C2800, C3300

N/A

Aficio MP C3500, C4500

N/A

Aficio MP C4000, C5000

N/A

Aficio MP C6000, C7500

N/A

Aficio 2051, 2060, 2075

N/A

Aficio 3025, 3030

N/A

Aficio 3035, 3045

N/A

Aficio 3224C, 3232C

N/A

Aficio 3228C, 3235C, 3245C

N/A

Aficio 3260C

N/A

Aficio Color 5560

N/A

Pro906EX, 1106EX, 1356EX

N/A

The models listed above are supported with the latest build of PCC 3 unless otherwise noted.

 

Equitrac Embedded for Ricoh ESA (v2.0.5) for Equitrac Professional 5

  

Aficio Model Java Version
MP 2553, 3053, 3353 (***) 11.x is pre-installed
MP 2554, 3054, 3554 12.x is pre-installed
MP 305 (**) 12.34.01 or higher
MP 4054, 5054, 6054 12.x is pre-installed
MP 501, 601 (**) 12.38.04 or higher
MP 6503, 7503, 9003 (**) 12.31.03 or higher
SP 4510SF (***) 11.x is pre-installed
MP C2003SP, C2503SP 11.x is pre-installed
MP C2004, C2504 (**) 12.35.01 or higher
MP C3003, C3503 11.x is pre-installed
MP C3004, C3504, C4504, C5504, C6004 (**) 12.35.01 or higher
MP C306Z, C406Z 12.x is pre-installed

MP C401

12.x is pre-installed

MP C4503, C5503, C6003

11.x is pre-installed

MP C6502, C8002

11.x is pre-installed

Aficio MP 2352

7.15.04 or higher

Aficio MP 2550, 3350

4.16 or higher

Aficio MP 2851SP, 3351SP

4.18 or higher

Aficio MP 2352, 2852, 3352

7.15.04 or higher

Aficio MP 4000, 5000

4.16 or higher

Aficio MP 4001SP, 5001SP

4.18 or higher

Aficio MP 4002, MP 5002

10.09 is pre-installed

Aficio MP 6001, 7001, 8001, 9001

5.05 or higher

Aficio MP 6002, 7502, 9002

10.09 is pre-installed

Aficio SP 5200, 5210

7.13.03 or higher

Aficio MP C2050(*), C2550(*)

4.16 or higher

Aficio MP C2051, C2551

7.x is pre-installed

Aficio MP C2800, C3300

4.16 or higher

Aficio MP C3001, C3501, C4501, C5501

7.x is pre-installed

Aficio MP C3002, MP C3502

10.09 is pre-installed

Aficio MP C4000, C5000

4.16 or higher

Aficio SP 5200S, 5210SR/SF

7.13.03 or higher

Aficio MP C4502,MP C5502

10.09 is pre-installed

Aficio MP C6000, C7500

4.16 or higher

Aficio MP C300, C400

7.09 or higher

Aficio MP C6501, C7501

7.x is pre-installed

Pro 8100S, 8110S, 8120S

11.x is pre-installed

Pro 907EX, 1107EX, 1357EX

5.05 or higher

Pro C5100,S C5110S (Ricoh Controller Only)

11.x is pre-installed

The models listed above are supported with ESA 2.0.5 unless otherwise noted

Devices with Fiery Controllers are not supported.

 

(*) Requires 512MB upgrade to run Java solutions.
  

(**) These devices are currently only supported in standard mode with the ESA Java component, needs latest device firmware.  

(***) The Hard Disk Drive option is required to run embedded ESA.

 

 

Ricoh ESA (v1.1) for Equitrac Professional 5

  

Aficio Model Java Version

Aficio MP 5500, 6500, 7500

2.11 or higher

Aficio MP 6000, 7000, 8000

2.11 or higher

Aficio MP 9000, 1100, 1350

2.11 or higher

Aficio MP C2000, C2500, C3000

2.11 or higher

Aficio MP C3500, C4500

2.11 or higher

The models listed above are supported with the latest version of ESA 1.x unless otherwise noted.

 

InfoPrint for Equitrac Office and Equitrac Express

  

InfoPrint Model Minimum Software

1930 MFP, 1940 MFP (de/dte)

LR.BS.P523-0

1850 MFP, 1860 MFP

LR.MN.P525-0

1870 MFP (dn/dtn)

LR.MN.P525-0

1880 MFP

LR.MN.P525-0

Color 1846 MFP, 1856 MFP, 1866 MFP

LR.FL.P522-0

1948 MFP, 1968 MFP, 1988 MFP

LP.SP.P521-0

 

Supported Card Readers

Click here for a list of supported card readers and card formats.

    

For quality purposes, we recommend confirming specific models, firmware versions, and Equitrac solution versions with your local Equitrac representative.

 

Last updated on 24 August 2016

   France
ncom_bu_pro_eq_spdv_rich

Choose your country.